Do we need a 32 bit version still?

//Do we need a 32 bit version still?

Do we need a 32 bit version still?

I have had v3.0.3 of Quickhash nearly ready for release for several weeks now, but the reason for the delays are twofold. One problem is Apple OSX, and it’s enforcement of 64-bit applications, which are surprisingly harder to compile than you might think. 32-bit is easy, but 64-bit is a fiddle using Lazarus.

On the other hand, 64-bit on Windows and Linux is easy. 32-bit is the fiddle with those two.

As it stands, whenever I compile the latest version, I have to compile it for 54-bit using Linux and Windows 64-bit operating systems. Then I have to launch virtual 32-bit versions of the same operating systems using VirtualBox. Then I have to compile a 32-bit version on Apple OSX, and, now, also have to work out how to do it in 64-bit. It’s exhausting and given the fact that nearly everyone these days has 64-bit versions of Windows, Linux and OSX, I am thinking of not bothering with 32-bit version anymore. We have had one available since 2011, and now it is 2019, I really don’t think it is necessary. Do you? If so, cast your vote and ideally also comment below. Thanks

By |2019-01-10T19:13:30+00:00January 6th, 2019|News|2 Comments

About the Author:

2 Comments

  1. bill page 13/01/2019 at 22:25 - Reply

    Just installed the 32bit version. I use an old Dell D820 laptop for volunteer work. It can’t run x64. But I can run win10x32 (just installed as I’m not allowed to use win7 anymore. And with an SSD stills is reasonably peppy). I probably could get away with running it on another x64 machine but checking files on this one is certainly more convenient.

  2. R Sumrall 08/01/2019 at 18:01 - Reply

    I don’t see the need for 32-bit these days.

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.